[altusmetrum] AltosUI v1.8.1 (and 1.8.2) (+ EasyMini?) bug in acceleration, speed, etc

Bryan Duke bryan at thedukes.org
Mon Sep 18 22:09:58 MDT 2017


Just as I got done testing this in 1.8.1, 1.8.2 came out — so, I retested and still have a bug report.

I flew another flight on my 29mm min-diameter rocket this weekend & the data views in AltosUI looked incorrect. The graphs & flight stats in AltosUI v1.6.8 looked correct, but both 1.8.1 and 1.8.2 look like at least the max speed & acceleration are wrong.

I tried both Windows & macOS and I’m seeing the same problem on both. I reinstalled v1.8.0 on a Mac and it still shows bad numbers. Is perhaps your new forward/backward filter added in v1.8 is messing with things? I’d really love it if you told me the altitude is being reported low, but it looks like the altitude is probably fine.

Here are screenshots from AltosUI of the same data file:
https://imgur.com/a/l2muV <https://imgur.com/a/l2muV>

If it helps, here’s one of my data files where I see the problem:
https://www.dropbox.com/s/cjxf7l19ucdxyrl/2017-05-27-serial-3288-flight-0003.eeprom?dl=0 <https://www.dropbox.com/s/cjxf7l19ucdxyrl/2017-05-27-serial-3288-flight-0003.eeprom?dl=0>

Also, somehow my flight data file from this weekend got corrupted. I’m not sure if it was v1.8.1 that did it or something else. It worked fine until I started troubleshooting this problem, so maybe bouncing back & forth between AltosUI versions messed it up somehow. Here’s that file (now just shows zeros or bogus data in AltosUI): https://www.dropbox.com/s/dpn7x2t5npjtyrs/2017-09-16-serial-3288-flight-0009.eeprom?dl=0 <https://www.dropbox.com/s/dpn7x2t5npjtyrs/2017-09-16-serial-3288-flight-0009.eeprom?dl=0>

Thanks,
-Bryan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gag.com/pipermail/altusmetrum/attachments/20170918/5513e228/attachment.html>


More information about the altusmetrum mailing list