[altusmetrum] TeleDongle v3 FW Programming Question

Bdale Garbee bdale at gag.com
Tue Mar 31 17:20:07 MDT 2015


Dennis Lappert <dmlappert at gmail.com> writes:

> Okay.. Then best way to keep TeleBT current is?

You really don't need to update TeleBT or TeleDongle every time unless
the release notes indicate that you should.  The over-the-air packet
protocol and data rate haven't changed in a very long time...

Having said that...

You need one of our devices with a 'companion port' to use as a
programmer, and a 'pair programming cable' which we used to include in
our early starter packs to connect the companion port on the programmer
device to the debug port on the target you want to update.  The pair
programming cables are currently marked out of stock in the store but
I'll make some up later this week when I get home from my current
$dayjob travel.

Products with companion ports include TeleDongle v0.2, TeleBT v1,
TeleMetrum, TeleMega, and EasyMega.

We had to leave the companion port out of TeleDongle v3 to get the new
circuitry to fit, and it also won't be present in the new version of
TeleBT that's nearing production.

Bdale
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 810 bytes
Desc: not available
URL: <http://lists.gag.com/pipermail/altusmetrum/attachments/20150331/f39cf163/attachment.sig>


More information about the altusmetrum mailing list